Author Topic: Running VoiceAttack as an Administrator  (Read 1738 times)


  • Administrator
  • Hero Member
  • *****
  • Posts: 1705
Running VoiceAttack as an Administrator
« on: January 13, 2018, 08:19:09 pm »
You may have had an application or game that you would like to control with VoiceAttack, but no matter what you do, you just cannot get VoiceAttack to communicate with it.  You've tried adding extra pauses, you've made sure your app targeting (send commands to) is correct.  You've even tried sending the key presses (or mouse clicks) to Notepad and they work just great.  So, what's going on?

It's possible that the game or application you are trying to communicate (send keyboard key presses or mouse clicks) with is being protected by Windows.  That is, Windows is blocking VoiceAttack's communication with that game or app.  The reason for this is simple:  Windows will not allow an application running in a lower security context from accessing an application running in a higher security context.  What that means is that an application that is given special rights to your computer (like being able to open other applications, communicate with certain apps in various ways, delete, create or modify files, etc... you know... the dangerous stuff) is not allowed to be told what to do by an application that does not have the same level of rights.  This is a very good thing, as it prevents rogue applications from doing all kinds of harm to your system.  So, when VoiceAttack (which is probably NOT running as an administrator), tries to access, say, Photoshop, which (for some reason only you would know) is running as an administrator, Windows will simply block VoiceAttack's access.  While I'm down here on this topic, I'd like to add that you've probably got to have a *really* good reason to need to run an application as an administrator on your computer (going to be bold here and say you've probably done it by accident).  You may want to evaluate why you are running the application as an administrator.

So, if you are at this point and you've decided that the application you are trying to target MUST remain running as an administrator, and you've really got to have VoiceAttack send input to this application (and the communication is blocked, based on everything we've covered), there's only one thing you can do in this case, and that is to run VoiceAttack as an administrator.

Since you probably already know how to do this, and also since there is tons out on the web on how to run an app as an administrator, I'm just going to link a Google search for you:

Now that you've got everything working like you'd like it to, you're probably experiencing the next phase:

"I don't like the pop-up box I get when I run VoiceAttack as an administrator."

Running any application as an administrator will cause the User Account Control (UAC) box to present itself.  Each.and.every.time.  Unfortunately, if you are running other apps as an administrator and you need VA to be able to send input those apps, this is the way it's going to have to be.  I don't like it, either.  It's a hassle, and it would be great if you could exclude certain trustworth, frequently-used apps easily, but that's just not the case.  The only alternative is to turn off UAC or try some hacks.  I don't recommend turning off UAC, and won't cover it here.  If you're into some hacky-ness, you can see if this helps (seems the least hack-y):

On a side note, in very *rare* instances, an application may not allow keyboard and mouse input from anything other than hardware.  Again, this is a very rare thing, so, you'll want to check with the good folks here in the VA forums to discuss the possibility of your game or app blocking input.

I hope that sheds some light on the whole running as administrator thing. 
« Last Edit: January 14, 2018, 12:21:53 pm by Gary »