Author Topic: First Voice attack plugin setup help  (Read 91 times)

T Kouvo

  • Newbie
  • *
  • Posts: 2
First Voice attack plugin setup help
« on: July 15, 2017, 06:27:23 am »
Hello all!

I'm working on setting up my first VA plugin and can use some assistance. It's in C# compiled using Net 4.6.2. I basically just setup a blank library with a class and added the 7 required function specified in the help manual and confirmed matching the ones in the sample. (I had originally misspelled a function name)

When I take the .dll from the project/build/debug/ and put it in the apps sub directory in its own folder it does not appear in the list of activated add-ons in voice attack. It does return a unique GUID, and strings for the plugin info.

Is there something I'm missing? I'm also typing this from memory, so hopefully I got all the details right.

Thank you.

T Kouvo

  • Newbie
  • *
  • Posts: 2
Re: First Voice attack plugin setup help
« Reply #1 on: July 15, 2017, 09:08:41 am »
Found the solution.

When generating the GUID using the VS tool it put spaces in between the character sections.
I.E{ 2F062FAA - A81B - 4F3D - BC74 - C91BF63EEC43} (not my plugin guid, just an example)

It needs to be formatted without spaces {2F062FAA-A81B-4F3D-BC74-C91BF63EEC43}.

Gary

  • Administrator
  • Hero Member
  • *****
  • Posts: 1153
Re: First Voice attack plugin setup help
« Reply #2 on: July 15, 2017, 09:36:27 am »
Yeah, that will certainly break when trying to convert it to a Guid ;)

I was going to suggest that you compile your plugin as .net framework 4, as the version of VA you have is most likely 4.  The next beta of VA will be compiled with .Net framework 4.5 (I try to keep the version of the framework as early as I can to maximize compatibility).