Recent Posts

Pages: [1] 2 3 ... 10
1
How Do I? / Re: joystick buttons
« Last post by Gary on May 21, 2018, 12:53:21 pm »
You will want to take a look at this thread, up near the top of the 'Frequently Addressed Topics' board:  http://voiceattack.com/SMF/index.php?topic=463.0
2
How Do I? / joystick buttons
« Last post by Eleuth on May 21, 2018, 12:42:20 pm »
I have a X56 Saiteck Hotas.
I installed the stick and throttle.
When I test the buttons are working.
But when I want to assign a speech command (say: gear up) to one of the buttons, there is no way to assign the buttons.
I can only assign key presses.
I have no VA or whatever.
I just want voiceattack execute the button command of the joystick if I give a speech command.

Is this possible ?
I can't find a solution on the forums and certainly not in the difficult to read online manual
Any help would appreciated.
Thanks
3
Issues / Re: VA won't recognize Warthog HOTAS buttons.
« Last post by Minto Took on May 21, 2018, 09:26:12 am »
Are the buttons on the stick recognized, Minto?

Yep.

Is there a limit somehow to the number of DX devices/buttons that VA can accept commands from (too small variable in the code?)?

All other software I use can recognize commands from all four devices at once (DCS, for example).
VoiceAttack can only poll 2 devices at a time(It will recognize all DirectInput devices plugged into the system, but you can only actively use two of them), though there shouldn't be a limit on the amount of buttons per device.

Did you assign the throttle as a joystick within VoiceAttack?

Did that too. I didn't do any hat switch configuration since the button I want to use isn't associated with a hat switch.
4
Issues / Re: VA won't recognize Warthog HOTAS buttons.
« Last post by Pfeil on May 21, 2018, 06:24:50 am »
Is there a limit somehow to the number of DX devices/buttons that VA can accept commands from (too small variable in the code?)?

All other software I use can recognize commands from all four devices at once (DCS, for example).
VoiceAttack can only poll 2 devices at a time(It will recognize all DirectInput devices plugged into the system, but you can only actively use two of them), though there shouldn't be a limit on the amount of buttons per device.

Did you assign the throttle as a joystick within VoiceAttack?

Click , in the "General" tab click "Joystick Options", click "Assign 1" or "Assign 2", select a device from the list, click "OK", if you have POV hats on that device check the relevant "Enable Joystick X POV HAT Switches" options, click "OK".

You can now use the device you assigned within VoiceAttack, up to two devices can be assigned and used in this way.
5
Issues / Re: VA won't recognize Warthog HOTAS buttons.
« Last post by Gary on May 20, 2018, 10:52:36 pm »
Are the buttons on the stick recognized, Minto?
6
Issues / Re: VA won't recognize Warthog HOTAS buttons.
« Last post by Minto Took on May 20, 2018, 09:27:11 pm »
I have the same issue as well.

Connected controllers as they appear in VA:
CH Rudder Pedals
CH Throttle Quadrant
Warthog Joystick
Warthog Throttle

I'd like to use buttons on the Warthog throttle for VA, but VA doesn't recognize any Warthog throttle buttons. Is there a limit somehow to the number of DX devices/buttons that VA can accept commands from (too small variable in the code?)?

All other software I use can recognize commands from all four devices at once (DCS, for example).

I tried uninstalling all my USB devices and reinstall to just keyboard, mouse, Warthog stick and throttle, and CH pedals. Same issue where VA can't read the Warthog throttle buttons. All Warthog drivers and firmwares are latest.

edit: VA version 1.7.0.6 (prerelease)
7
Issues / Re: VA regularly crashing after brief period Resolved
« Last post by LM on May 20, 2018, 07:43:49 pm »
Hi jbartoli -

Thanks for the info you posted. I read it and made one change: Audio Output type is "set to Integrated Components".

That did it. It was on Windows Media Components. I hadn't changed it to that, so either I'd been using it all along and the recent VA, Windows, or headset driver updates didn't like it, or the VA update changed my settings (doubtful - all other settings seemed to be as I'd left them).

Thanks again!
8
Issues / Re: Erratic Mouse Movement
« Last post by Mark L on May 20, 2018, 11:07:32 am »
I've tested it with an old mouse and it seems like that's where the problem is, strange. Oh well, looks like I'll have to shell out for a new one then.
9
Issues / Re: App volume and device preferences
« Last post by Robertsmania on May 20, 2018, 08:32:46 am »
Splendid news! You rule.

And just for some comic value, this is one of the things that happens on my stream when Che Volume malfunctions.  The audio from VoiceAttack and iRacing constantly goes up in pitch!
https://www.youtube.com/watch?v=7IeSm4CZ7ps
10
Issues / Re: VA regularly crashing after brief period
« Last post by jbartoli on May 20, 2018, 07:43:55 am »
Additional Info:  I think I found a fix (at least for my issue).  My version of the plugin EDDI is 3.0.1-b2 (a beta)  and after troubleshooting it seems that EDDI causes the crash as it's initialized when VoiceAttack starts up.  The solution (for me) was to make sure that VoiceAttack  had the following set on the configuration panel:

Recognition Tab - Make sure the speech engine is set to system default.

Audio Tab - Ensure the "Set windows default audio" playback and recording boxes are check and set with the Change Now button.  And make sure the Audio Output type is set to Integrated Components.

General Tab - Enable Plugin Support

Obviously these setting might be different for you depending on your setup but playing around with these setting might fix the issue for you. 


Good luck
Pages: [1] 2 3 ... 10